Rated 5 out of 5 stars

Very, very nice. I have my Google toolbar back! Why they only support it for a browser that only has a 39% market share is a mystery to me. This works great. Thanks so much.

Rated 5 out of 5 stars

muito bom graças a ele recuperei minha barra de ferramentas do google

Rated 5 out of 5 stars

Very nice, thank you. I've found a lot of news telling that the version check should be disabled since Firefox 10, but that doesn't seem to be the case. A lot of add-ons were incompatible with the silently installed Firefox 11 today, so this add-on came to my rescue.

Rated 5 out of 5 stars

This is the only one that has worked on my U3 Thumb drive for Firefox 10.0.2. Don't ask me how as I had tried ALL the manual tricks all these extensions do. I'm baffled.
I used this as a last resort as none of the other compatibly tricks worked. I had tried Add-on Compatibility Reporter (even though it's not needed anymore since ver 10) I also tried Nightly Tester Tools.
It did not make them all compatible but thank you for the few that this extension actually Did made work

Rated 5 out of 5 stars

This is an absolutely essential add-on given the INSANE update schedule and version number inflation Mozilla is now using.

Rated 5 out of 5 stars

I'm very happy to have this, especially for Thunderbird.

Thanks for developing it.

Rated 5 out of 5 stars

Works as advertised. Now I can use the last decent version of Adblock Plus with Seamonkey 2.6.1

EDIT 20 January 2012 : It also allows me to continue using my favourite Firefox theme in 9.0.1

Rated 5 out of 5 stars

Works, saved my ass :)

Rated 4 out of 5 stars

This extension works well, but I have to re-install it every time I restart Firefox. It's a little bit of a PITA, but it gets the job done.

Rated 5 out of 5 stars

Works Great even with the new add-ons default to compatible feature on the latest Fx(Nightly). This extension allows me to enable incompatible themes, since themes are excluded from the default to compatible feature on the latest Fx(Nightly).

Rated 2 out of 5 stars

There really is no way around it when "Disable Add-on Compatibility Checks" isn't compatible with Firefox 8. :x
I'm sure that you need to use this one carefully, as there's ...-usually- a reason as to why something is marked incompatible, but with that in mind then, it should be compatible with newer versions, because we certainly can't use this add-on on itself. (that would be redundant or paradoxical)

Rated 5 out of 5 stars

Kris, this is what I've been looking for on Aurora 10.0a2. Now all my favorite extensions work again.

Rated 3 out of 5 stars

On Version 7 you need only set extensions.checkCompatibility.nightly and it will always work for future versions like Version 8 and so on

This review is for a previous version of the add-on (1.1.1-signed.1-signed). 

This is true, but it doesn't help Aurora, Beta, and release users who want to use add-ons not yet marked compatible.

Rated 5 out of 5 stars

Works great!

This review is for a previous version of the add-on (1.0.1-signed.1-signed). 

Rated 5 out of 5 stars

Thank you for this! Works great in Aurora 5.0a2.

By the way, there is a typo in the URL when trying to access the homepage via the addons manager. The hypen in check-compatibility needs to be removed.

This review is for a previous version of the add-on (1.0.1-signed.1-signed).