Rated 2 out of 5 stars

States "Works with 2.0 - 74.0a1" here but reports "Incompatible with 68.5.0"

This review is for a previous version of the add-on (1.02).