Rated 4 out of 5 stars

Please enable usage in TB 82+.

This website limits the maximum version that can be selected. Alternatively, one could theoretically do without the Max version, which can later become a problem for "normal" users. Are you using beta versions? Then please be able to adapt the max version of an add-on yourself.